
 

  

Version: 5.3.1 
Date: June 2017 

RELEASE NOTE  

TaroTM  
Leading RAM tools for responsible and profitable performance 

 

 

 

 

 

 

 

 

 

 

 

  



   
 

 
 

   
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Prepared by: DNV GL - Software  

 

© DNV GL AS. All rights reserved  

This publication or parts thereof may not be reproduced or transmitted in any form or by any means, 

including copying or recording, without the prior written consent of DNV GL AS  



   
 

| Release Notes | Taro 5.3.1 | June 2017 | www.dnvgl.com/software  Page i 

 

 

 

TABLE OF CONTENTS 

TABLE OF CONTENTS .................................................................................................................... I 

1 WELCOME ...................................................................................................................... 3 

2 WHAT’S NEW? ................................................................................................................ 5 
2.1 Transient Yields ................................................................................................................................. 5 

2.2 Flow table view .................................................................................................................................. 7 

2.3 Maintenance Tab at the Simulator Parameters ............................................................................... 13 

2.4 New Comparison View .................................................................................................................... 14 

2.5 Running models from a server ........................................................................................................ 20 

2.6 Improvements to the Interface ....................................................................................................... 20 

2.7 Minor usability enhancements ........................................................................................................ 21 

3 MOVING TO TARO 5.3 ................................................................................................... 23 
3.1 Converting models from generation 4 to generation 5 ................................................................... 23 

3.2 Forward compatibility in the new platform: Taro 5 ......................................................................... 23 

3.3 Change of file format ....................................................................................................................... 23 

4 FEEDBACK ................................................................................................................... 24 

5 HOW TO UPGRADE ........................................................................................................ 24 
5.1 Downloading the installation package ............................................................................................. 24 

5.2 Taro 5.3 Installation Process ............................................................................................................ 26 

5.3 License for Taro 5.3 ......................................................................................................................... 29 

6 MAKING THE MOST OF THE DOCUMENTATION ................................................................. 29 
User Manual ............................................................................................................................................... 29 

Help system ................................................................................................................................................ 29 

Blog ............................................................................................................................................................. 29 

Videos ......................................................................................................................................................... 29 

Frequently Asked Questions ....................................................................................................................... 31 

Tutorials ...................................................................................................................................................... 33 

Release Notes ............................................................................................................................................. 34 

7 TECHNICAL HELP .......................................................................................................... 34 
7.1 Report a Problem Feature ............................................................................................................... 34 

7.2 Direct email ..................................................................................................................................... 36 

7.3 Telephone contact ........................................................................................................................... 36 

8 FOR SYSTEM ADMINISTRATORS: TECHNICAL NOTES ........................................................ 37 



   
 

| Release Notes | Taro 5.3.1 | June 2017 | www.dnvgl.com/software  Page ii 

 

 

System Requirements ................................................................................................................................. 37 

 



   
 
 

| Release Notes | Taro 5.3 | November 2016 | www.dnvgl.com/software  Page 3 

 

 
 

 

1 WELCOME 

Welcome to Taro 5.3.  

This was a short development project, with only 7 months of duration, where the focus has been to 

extend the current modelling capabilities to include features coming from Maros, more stability and 

usability features. 

Taro has now the ability to define transient yields for the different process units. In previous versions, 

the implementation of transient yields included defining multiple units with phase-in and phase-out – this 

approach increases the size of models and it makes it difficult to perform quality checks. With this new 

feature, the definition of transient yields is directly performed at the Node property window inside the 

Products tab. 

 

Figure 1: Transient Yields 

A feed to a plant can be variable in nature. If the variation trends have a predictable nature i.e. a 

capacity increase over time, a seasonal variation, then they should be modelled defining the profile and 

the possible variations inside each time-span. The Flow Grid view has been introduced to Taro allowing 

users to specify flow changes for all feed nodes.  

 

Figure 2: Flow Grid 
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Furthermore, improvements to the interface have been introduced based on customer feedback to the 

recent change of the Ribbon Tabs. For example, the zoom bar has been moved to the bottom right of the 

application leaving more space to the Home Tab. Additionally, the Grid button has been removed and a 

new layout introduced to make it easy to access the different grids. 

 

Figure 3: New layout for the Home Tab 

A new Comparison View has been added to the Results View application allow users to easily compare 

results from multiple cases. 

 

Figure 4: New Comparison Mode at the Results View 

This version extends the concept of Rate Operations to allow a change in the production rate to initiate 

an independent event. The independent event is triggered once the threshold level and direction are 

breached; it is important to note that, by default, the event will be repeated sequentially for as long as 

the threshold is breached. 

We hope you enjoy the experience of using Taro 5.3.  

Please let us know what you think at software.support@dnvgl.com or sending your feedback directly to 

Victor Borges.  

http://www.wipo.int/contact/en/area.jsp?area=web
mailto:software.support@dnvgl.com
mailto:victor.borges@dnvgl.com
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Your comments, suggestions and requests will help us shape the further evolution and improvement of 

DNV GL’s RAM software tools. 

2 WHAT’S NEW? 

2.1 Transient Yields 

Different types of crude oil yield a different mix of products. Crude oil types are typically differentiated 

by their density (measured as API gravity) and their sulphur content. Crude oil with a low API gravity is 

considered a heavy crude oil and a larger yield of lower-valued products. Therefore, the lower the API of 

a crude oil, the lower the value it has to a refiner as it will either require more processing. Thus, being 

able to define transient yields, based on different the delivery of different crude oil types, is an important 

parameter when simulating the performance of refinery is the ability to. 

With the current version, if the user wants to set up a transient yield, there is a need to define multiple 

units with phase-in and phase-out – this approach increases the size of models and it makes it difficult to 

perform quality checks. 

The new Transient Yield feature allows users to set up time-based yields directly at the Node property 

window inside the Products tab. 

The first row of the grid refers to the existing definition of the yields. The selected date is always the first 

day of the start year. 

 

Figure 5: Products tab in the Node properties window 

The transient yields grid is validated and the values in the columns with the Product Stream description 

must always sum to 100%. 
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Figure 6: New row has been inserted in the Transient yields grid 

Taking the following example where a different type of crude is expected to be delivered during the 

second year of production for a refinery – this will make the efficiency of the different units in the plant 

vary. For example, during the second year, the production engineers expect the Hydrocracker unit to 

produce 12% of Naphtha, 31% of kerosene and 57% of Vacuum gasoil. 

This can be easily defined at the Products tab in the Hydrocracker units: 

 

Figure 7: Example of the Hydrocracker 

Running the simulation engine will produce the following stages of normal production for the 

hydrocracker unit. The animation mode shows: 

1st year) 
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Figure 8: Normal production for the Hydrocracker during the first year 

2nd year) 

 

Figure 9: Normal Production for the Hydrocracker during the second year 

 

2.2 Flow table view  

The Flow table view provides a spreadsheet like method of specifying flow changes for all feed nodes. 

Feed nodes are defined as nodes with no upstream connection. 

A feed to a plant can be variable in nature. If the feed variations are the results of unpredictable events, 

then these variations should be modelled using appropriate failure modes. If the variation trends have a 

predictable nature i.e. a capacity increase over time, a seasonal variation, then they should be modelled 

defining the profile and the possible variations inside each time-span. 

Configuring the Flow table 

To access the Flow Grid, select  from the Grids area as shown below: 

 

Figure 10: Flow Table location 

A table of and a spreadsheet like view should appear, as shown below, which has a Date/Time column 

and a column for each Node. If you wish to return to the previous view just click on the Flow Grid 

Button. Alternatively, select one of the Views using the Grid area of the Home tab. 
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Figure 11: Flow table interface 

Clicking on the drop-down icon, as show in Figure 12, will add a new row which will start of at the 

current year but the user can pick up any date from the calendar window. In the calendar facility, the 

user can select the year, month and date. If the user decides to type in the dates, please note that the 

date format is yyyy/mm/dd hh:00 where yyyy is a four-digit year, mm is a two-digit month, dd is two-

digit day and hh is a two-digit hour value based on the 24-hour clock. The minute’s value is there purely 

for display purposes and cannot be altered. Also, dates before the start year should not be entered nor 

should February 29th on leap years.  

 

Figure 12: Method for adding new rows representing flow changes 

A row represents a discrete change to the production rate for all the feed nodes and, initially, all capacity 

values are set to the node design capacity. This will be displayed in Italic greyed out. 

Another method of adding rows to the Flow table view is by right-clicking on the “+” button and selecting 

from two options: 

- Insert Row which will produce a default date which will be at the start of the current year  

- Insert Series 
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Figure 13: Clicking on the “+” button will display a dialog with more options 

The series configuration can be used to insert rows where more than one row is required and the rows 

are equally spaced in time. This facility is useful where, say, the data changes on a yearly or monthly 

basis. 

The process to insert a series of rows to the flow table is described below: 

 Open the flow table through the View menu at the top right hand side of the software  

 Right-click on the “+” icon - Figure 14 

 Select the option to Insert Series Figure 14 

 If the option to Insert a Series, another dialog will open, shown at Figure 14 

 
Figure 14: Inserting Rows and Series and Series configuration window 

To set new flow rates, simply click on each field and enter the appropriate flow rate for this time. The 

capacity format is by volumetric flow and units are taken from the Simulator Parameters and shown on 

the top of the Flow grid. 

It is important note that the Flow Grid currently allows users to enter Constant rates and visualise all the 

remaining Rate Profile distributions. To edit the latter, users must access the Rate Profile tab at the Node 

Property. 

The user can easily access the property window by right-clicking on the Node name at the top of the 

respective column at the Flow Grid and selecting “Full Properties [Node name]”. The reference node will 

also be selected the node at the Hierarchical tree, as shown below: 
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Figure 15: Right-click on the Reference Node at the top of the Flow Grid to access the full 
node properties 

After selecting the full properties window, the Rate Profile tab is displayed: 

 

Figure 16: Rate Profile full node properties window 

After defining the distribution and pressing “OK” to the window, the distribution name will be displayed 

at the Flow Grid with its respective parameters. 

The order parameters are displayed in the following order on the grid: 

- Normal: Expected Rate and Standard Deviation 

- Rectangular: Minimum and Maximum rate 
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- Triangular: Minimum, Mean and Maximum rate 

- Weibull: Characteristic life and Shape Factor 

- CDF: displays the distribution name 

- Table: displays the table name 

 

Validation 

Any node value that exceeds its capacity, the Node Design capacity, set up at the Node properties, will 

show a validation problem.  

If you right on the Node with the warning sign, the error tab will show the following message: 

 

Figure 17: Error window for Feed 1 and Process respectively 

This will not prevent the user from running the model.  

To fix this the user must either reduce one or more feed node capacities until the error condition 

disappears. If the capacities are valid then you should increase the Node Design Capacity in the Node 

showing the error. 

Node ordering in the Flow table 

In the Flow table, the nodes are displayed in a specific order (using the Sequence Number method). The 

nodes are separated into groups with a matching number steps from the source nodes. This ensures that 

all the source nodes appear as the first columns in the grid table. Within these groupings the node 

positions are in order of node number with lowest number first. 

Where there is more than one upstream path to a source node, the grouping of a node will be dictated 

by the highest number of steps from any source.  

Viewing production rates entries 

Once all the periods and production rates have been entered and checked it is possible to view these in 

graphical form. Selecting the graph button  from the top right of the flow table will display all the 

feed capacities as a stacked bar chart. Contributors to flow can be stacked (area) or unstacked (line) by 

using the graph property window: 
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Figure 18: Stacked Contributors and graphing one or all streams 
 

Copying/Pasting Grid Data 

You can use copy and paste to move date and value data to and from the grid. Data can be selected 

from an individual cell, a group of cells, a row (left-mouse click on one of the left-hand indexes), a 

column (left-mouse click on one of the headers) or from the whole table (left-mouse click on the empty 

grey area in the top left corner). Once selected clicking on the Edit>Copy menu item will place that data 

in the clipboard. This data can then be copied into Excel, manipulated and pasted back in. 

Pasting into the Flow table view is simple; just paste the clipboard data into a cell in the Grid and the 

data in the clipboard will be pasted into a matching column and row block. Since the Flow table view is in 

a specific format relating to timed node flow value changes there are rules about what may be pasted 

into the grid from Excel. The following rules apply: 

- The copied area must only contain numerical and date data. If dates are included they must only 

be in the first column. 

- If the copied data from Excel includes dates the clipboard data must be pasted into a cell in the 

first column of the grid, i.e. the date column. 

- When pasting data into the product stream table only dates and flow values for source nodes will 

be accepted on pasting since the intermediate and export node flows are automatically 

calculated. 

- Any data pasted into a disabled column will be ignored. I.e. any data pasted onto intermediate or 

export nodes in the table. 

- If you paste data into the table that does not include dates the data will overwrite the range of 

data currently present. If there are more rows in the clipboard data than there are below the 

destination paste cell, then more rows will be added taking an hourly time step as the step 

between the rows. 

- If there is no data in the Flow table, or you wish to append data to the table not overwrite, then 

the clipboard data should be pasted from Excel into the first empty cell in the date column. As 

detailed before, the clipboard must have a date column for new rows to be generated. 
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2.3 Maintenance Tab at the Simulator Parameters 

The entire list of keywords related to maintenance have been reviewed and a new interface has been 

designed to make them more accessible and easy to defined: 

 

Figure 19: New “Maintenance” tab at the Simulation Parameters 

The following section provides a quick description of each option:  

 

Default: By default, once a job is started it will be completed by overrunning the shift as required. 

New behaviour: Enforces a strict rule that there is no shift overtime, all jobs are interrupted at the end 

of a shift and re-started on the next day’s shift.  

If the Maintenance profile associated with the repair is of highest priority (i.e. Level 1 (priority 1-5), this 

keyword is ignored. 

 

Default: By default, mobilization delay will not be enforced for jobs which have been delayed and 

started on the next day’s shift and on jobs overrunning into the next day’s shift.  

New behaviour: This option enforces a mobilization delay for jobs which have been delayed and started 

on the next day’s shift and on jobs overrunning into the next day’s shift.  
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This option will align all planned maintenance activities forcing them to start at the same day. To define 

what activities are going to be aligned, the user must input a time range which will align all activities 

within that time range. Enter the number of days between 1 and 90 days. 

 

This option defines the minimum time spent on a job location before the end of a shift, which in turn 

controls the extent of mobilizations. This is to avoid situations for example where a crew arrive on 

location and start a job for a few minutes then are forced to return on the next day’s shift to complete 

the task. 

Enter the number of days between 1 and 90 hours. 

 

Default: By default, once a job is started it will be completed by overrunning the shift(s) as required. 

New behaviour: This option allows the user to stipulate the maximum allowable shift overrun before an 

interrupt is enforced. Enter the number of days between 1 and 90 hours. 

 

By default, all mobilization times less than 1day will be included in the man-hours expended, however, 

this can be overruled by using this keyword permits the user to stipulate an alternative threshold for 

inclusion.  

 

This option will optimise the maintenance resourcing by taking the maximum number of resources 

available and repairing all level 3 maintenance tasks in parallel. 

 

Default: By default, if there is currently a spare restock request in progress, subsequent restock 

requests for that spare will trigger a new order. 

New behaviour: If there is currently a spare restock request in progress, subsequent restock requests 

for that spare will be added to the existing order and be delivered at the same time as the original order. 

 

This option will enforce travel time between all the locations the maintenance resourcing by taking the 

maximum number of resources available and repairing all level 3 maintenance tasks in parallel. 

2.4 New Comparison View 

The Comparison View provides the ability to compare the results between different models. Typically, 

this would involve comparing the results between a base case and its sensitivity scenarios. However, the 

comparison view is not limited to models that are sensitivity cases – it will try to compare the results 

from different models when is possible. 
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Upon completion of the simulation process, the Results View will display two options on the top of the 

folder view: Base and Comparison. 

The Base refers to the Base Case model and will display all the results for the model currently loaded: 

 

Figure 20: Result View 

By checking the option "Comparison", the Results View will change its layout. A colourful column will 

display the results from the Base Case. 

 

Figure 21: Result View in the Comparison View 

2.4.1 Adding a Comparison case 

In order to add new cases for comparison, click on the hyperlink to the right of the Base Case legend: 
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Figure 22: Result View in the Comparison View 

This will prompt another window that allows the user to select a Results Database (e.g. file extension 

dmsd for Maros and dtrd for Taro): 

 

Figure 23: Selecting Results Databases 

After selecting the Results Database and clicking on Open, the new result set will be added to the 

Comparison View. A colour coding legend will separate the base case from the sensitivity case. The 

sensitivity case will take the Sensitivity Set name and it will show the results for the modified model. If 

the model name is an extension of the base case's name, the Comparison View will display only the 

extension e.g. Base Case = Refinery.dtrd and Sensitivity Case = Refinery - Sensitivity 1.dtrd; the 

display will show: Base Case = Refinery and Sensitivity Case = Sensitivity 1. 
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Figure 24: Example of Base case and Sensitivity case side-by-side in the Comparison View 

To replace an existing comparison model, click on the model to be replaced and the window will be 

shown again.  

To add more sensitivity cases to the Comparison View, simply click on the hyperlink again and select 

another Results Database. The results of up to four models can be displayed at the same time – one 

base case and three sensitivity case. 

2.4.2 Results display 

All the results comparisons are shown in the tabular format. In addition, many of the results can be 

displayed as graphs benefiting the users greatly in a more user-friendly results comparison. 

 

Figure 25: Similar options to display the results are also available for the Comparison View 
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Figure 26: Graphical display of the Criticality graph 

Another useful feature is the ability to display the delta between the different KPIs. By clicking on the top 

right of the screen will show 

 

Figure 27: Top-right button allows users to display the delta between Base Case and 
Sensitivity Case 
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Figure 28: Comparison View showing delta between cases 

This will display the delta between the Comparison case and the base case i.e. Potential Volume from 

Refinery.dtrd compared to Sensitivity 1.dtrd. 

The number of results folder available will depend on the features defined for the model. Currently, the 

Comparison view handles the following KPIs: 

 Event Criticality 

 Element Criticality  

 Subsystem Criticality 

 Element Type Criticality 

 Availability 

 Plant Performance Summary  

 Buffer Efficiency  

 Bulk Transport Group Utilization  

 Performance Signature 

 Production Efficiency 

 Resource Utilization 

 Consumption of Spares 

 Outage Report 

 Contract Losses 

 Net Present Value  

In case there is some incompatibility when comparing the results, a Comparison State table will be 

displayed as shown below:  

 

Figure 29: Comparison State provides information on possible incompatibility 

2.4.3 Removing a Comparison case 

After comparing results, it is important to remove the all the results databases from the Comparison 

View. If a results database is not removed from the Comparison View, the model is locked and the 

application will prevent the users from editing it. 

In order to remove a single case from the Comparison View, right-click on the hyperlink with the 

sensitivity case name and select "Remove Comparison Model "name"”, as shown below: 
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Figure 30: Right-click on the Sensitivity Name to Remove the comparison model 

In order to remove all the results databases – select the option to “Remove All Comparison Models”. 

2.5 Running models from a server 

Prior to Taro 5.3 a project model would be run directly from a server.  If the network was poor or the 

server was slow this would not normally slow down the simulation time but could slow down the results 

generation time. 

In Taro 5.3 all results processing is now done on the local computers “temporary” folder.  Once 

processing is complete the final results files are copied back to the network directory.  For slow networks 

this should show a major improvement in the time taken to generate results. 

2.6 Improvements to the Interface 

The picture below shows the Home Tab in Maros with a working model loaded. 

 

Figure 31: Taro user-interface 

You will notice the following improvements: 

Zoom Bar: has been moved to the bottom right of the application to allow for more space at the Home 

tab 

 

Figure 32: Zoom Bar 

The Grids button has been removed allowing users to easily access the seven grids available: 
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Figure 33: Grids Area in the Home Tab 

The same lay-out has been introduced to the Add Item area: 

 

Figure 34: Add Item in the Home Tab 

The “Switch Windows” button has been moved from the Views tab to the Home Tab: 

 

Figure 35: Switch Windows in the Home Tab 

 

2.7 Minor usability enhancements  

The Simulation Parameters have been changed to align with the reports and a few pre-defined 

parameters have been added: 
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Figure 36: Simulation Parameters 

The Operations log has been renamed to align with the actual log name – Event log output. The Cost 

data is now automatically defined to dollars to easy the process of defining lifecycle cost studies. 

Many users utilise the animation mode to perform quality checks to the model. In order remove one step 

in the process of getting the animation data, the box “Generate Animation data” at the Configure 

Simulator window is now automatically checked. 

 

Figure 37: Configure Simulator 

The batch run functionality has been extended to provide more information in case a model shows a fatal 

error throughout the simulation process. 
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The Transient area of the Parallel Grid now displays the name of the parallel unit: 

 

Figure 38: Transient area of Parallel Block Grid 

Please continue to suggest changes to the interface that facilitates your operation of the model. 

3 MOVING TO TARO 5.3 

3.1 Converting models from generation 4 to generation 5 

Users do not need to go through a conversion process to load existing models in Taro 5.3. When working 

with Taro 4 models, users can simply open an existing model in version 5.3 and re-run the application to 

see the results in the new format.  

Taro 5.3 will always create a backup version of the Taro 5 model with the extension jtrp4 at completion 

of the conversion process. 

3.2 Forward compatibility in the new platform: Taro 5 

Forward compatibility is also available for Taro.  

If a model is saved in newer version, users can open in an older version if the model contains no newer 

features. For example, if a Taro 5.3 model is saved with transient yields then it will not open in Taro 5.2. 

The following message will be displayed when trying to load the model in Taro 5.2: 

 

If that feature is removed and the model is saved, then it will load into Taro 5.2. 

3.3 Change of file format 

The file extension has been changed in the new platform Taro 5 to avoid confusion with version 4.x files.  

The new file formats are: 

Table 1: File formats in Taro 4 and Taro 5.3 

Application Document file extension Results file extension 

Old file format: Taro 4 .jtrp .jtrr 
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File format: Taro 5.3 .dtrp .dtrd 

4 FEEDBACK 

Feedback is essential for us to keep improving the user-interface and areas of particular interests 

regarding modelling assets and production scenarios. Please let us know of possible gaps that affect 

what you are or will be modelling. An important point is that you shouldn’t ignore minor issues, tell us 

about them (we don’t always know). 

It is important to get your team together and try to provide a wish list where you address the modelling 

challenges that you, as a company, will be facing soon. 

We won’t be able to do everything but we will prioritise based on the feedback. With this feedback our 

aim is to provide the most comprehensive solution for Oil and Gas RAM analysis in the market. 

5 HOW TO UPGRADE 

This section is intended to give general information regarding downloading, installing and licensing Taro 

5.3. 

5.1 Downloading the installation package 

All DNV GL RAM products can be downloaded via the DNV GL Software’s Customer Portal. In order to 

access the Customer Portal, please use the link below to log into the Customer Portal: 

www.dnvgl.com/cp  

 

Figure 39 - DNV GL Software customer portal 

After logging in to the Customer Portal, select the option “Get Software”, as shown below: 

http://www.dnvgl.com/cp
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Figure 40 - Home tab of customer portal 

By clicking Get Software you are taken to the Software Downloads Tab. Click Select Maros/Taro Library 

from the View dropdown list as shown in Figure 41. 

 

Figure 41 - View dropdown list 

Taro 5.3 will be listed at the top and marked as “Latest Version”. 
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Figure 42: Taro 5.3 at the Customer Portal 

 

Figure 43: Taro 5.3 download page at the Customer Portal 

Click the “Download” button to download the Taro 5.3 installation files. 

5.2 Taro 5.3 Installation Process 

The Taro 5.3 installation process will not override the existing version of Taro 4 but it will override the 

existing Taro 5.2 installation. You can therefore keep Taro 4 and 5.3 of Taro installed. 

Once the download is complete, you should: 

1. Check if you have windows administrator rights. 
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2. Extracting and running the installation package 

 

 

Figure 44 - Quickstart.html 

This will prompt your default browser to open. Simply click on “start the installation” at the bottom of the 

page, accept the installation to install the application and the process will be started.  

In order to install the program, you must have administration rights for the computer. Contact 

your System Administrator to check whether you have administration rights, or to obtain these 

rights. 

Unzip the content from the zip file to your local hard drive and click on the Quickstart.html as 

shown in picture below. Please do not try to run the Quickstart.html file from within the Zip file 

before the files are uncompressed as this may cause your installation to fail. 
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Figure 45 - Start the installation 

If Microsoft .Net 4.6 is not installed on your system, this tool must be installed before installing Taro. In 

order to install this tool, please go to the Installation section at the Quickstart.html file and select the 

link Microsoft .Net 4.6 Installation (English). 

 

Figure 46 - Microsoft .Net 4.5 Installation (English)  
 

Note: For another languages Microsoft .Net 4.6 can be installed directly from Microsoft or contact your IT 

department. 
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5.3 License for Taro 5.3 

No license request or import is required to start using Taro 5.3 if you already have a license file for 4 or 

5.2.  

In case you face any issues regarding license please contact DNV GL Software support team at 

Software.Support@dnvgl.com. 

6 MAKING THE MOST OF THE DOCUMENTATION 

Taro 5.3 presents different sources of information. Please find below a description of each of them:  

User Manual 

The Taro folder in the installation (typically under “Program Files (x86)\DNVGL”) contains a Taro user 

guide called Manual.pdf, which provides you with a wide range of information about the program, and 

should enable you to find answers to most of the questions you may have about Taro. The Taro guide 

contains all the Online Help pages and more and should be the main resource of information about the 

software.  

Help system 

The Online Help for Taro 5.3 is in the form of a *.chm file—a compiled HTML Help file. The file will be 

installed with the rest of the Taro 5.3 files when you install the program, and you will normally access it 

using the Help menu, but you can also open and read the file directly (located in the Taro 5.3 installation 

folder). 

In order to read the files, you must have Microsoft Internet Explorer Version 5 or later installed on your 

PC, although it does not have to be your default browser. You must also have some additional files that 

are specific to Microsoft HTML Help; these are installed automatically during the Taro 5.3 setup process, 

so you should be able to read the files directly if you have already installed Taro 5.3. 

Blog 

DNV GL Software’s blog discusses topical issues, challenges and market observations relevant for 

software for managing risk and improving asset performance: 

 

Figure 47: Blog button in the Help tab 

Videos 

Maros and Taro e-learning centre has been designed to support clients that are new to Maros and Taro.  

mailto:Software.Support@dnvgl.com
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Figure 48: Video button in the Help tab 

The idea is that we can add more videos to Maros and Taro e-learning centre so please get in touch with 

ideas of what you would like to see there. 

The videos currently available are: 

 Building up a model in 6 steps: This video describes the six main steps to build-up a Maros 

model.  

 Maintenance Resource Modelling in Maros and Taro: This video takes the model we created in 

the “Building up a model in 6 steps” and extends the model to account for Maintenance 

Resources Modelling.  

 Priority of Maintenance tasks: This video takes the model we created in the “Maintenance 

Resource Modelling in Maros and Taro” and extends the model to account for maintenance repair 

priority. 

 Lifecycle cost analysis: This video takes the model we created in the “Maintenance Resource 

Modelling in Maros and Taro” and extends the model to account for Lifecycle cost analysis.  

 Multi-product modelling and Production Capacities: This video describes how users should use 

the model multi-products in Maros.  

 Flaring operations: This video takes the model we created in the “Multi-product modelling and 

Production Capacities” and extends the model to account for flaring operations. 

 New Interface in Maros and Taro: This video describes the advantages of the new interface in 

Maros 9.2.  

 Implementing Planed Renewals using Maros and Taro: This video describes how to implement 

planned renewals in Maros.  

Optimising frequency of Planned Renewals: Sensitivity Manager can be used to optimize the 

frequency of Planned Renewals. 

 

 

 

 

 

 

  

https://www.youtube.com/playlist?list=PL2EsH0WLHwszPBoEOizgc_nKLotGFjAuz
https://www.youtube.com/watch?v=N1OZQCl6WDQ
https://www.youtube.com/watch?v=Xsk2T3G6yYE
https://www.youtube.com/watch?v=m4wR5c7ZkuQ
https://www.youtube.com/watch?v=VuXYAIXicEw
https://www.youtube.com/watch?v=ejOEoydBINw
https://www.youtube.com/watch?v=8kudvwBlW-I
https://www.youtube.com/watch?v=eupsny0ubeQ
https://www.youtube.com/watch?v=ueBDoFL-jpI
https://www.youtube.com/watch?v=wlORIdw1f3I
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Frequently Asked Questions 

These documents try to highlight the main aspects of Taro 5.3. The areas covered by the FAQs are: 

- Building a model in 6 steps 

- Maintenance modelling in 4 steps 

- Quick steps 

- Switches in unit operating modes 

- Breakdown of Utilisation Losses 

You can find these FAQs under the Help Menu: 

 

Figure 49: FAQs button at Help tab 

Clicking on FAQs button will prompt your default browser with a list of FAQs: 

 

Figure 50: List of FAQs 

Clicking on any item on the list will prompt another tab with the FAQ: 
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Figure 51: FAQ document 

You can also see the FAQs under the Taro 5.3 folder inside C:\Program Files (x86)\DNVGL\Taro5\FAQ. 

 

Figure 52: FAQ folder 

In case you need more information about a specific modelling approach or feature, please contact DNV 

GL Global support. 
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Tutorials 

The tutorials have been separated into two categories:  

- Guidelines on building models and; 

- Simple walk through modelling capabilities. 

For the “Guidelines on building models” category, users are led through the main steps to build either a 

full model or a section of a model.  

For the “Simple walk through modelling capabilities” category, users are advised to open a reference 

model to follow the steps described on the tutorials. 

Each tutorial is intended to focus on a specific set of features and asset. Obviously, the experience 

acquired when performing the tasks can be extended to model other scenarios/assets. 

You can find the tutorials at Help Tab by clicking on Tutorials.  

 

This will prompt another window: 

 

Figure 53: Tutorials folder 

In addition, Tutorials can be found in the Content tab of DNV GL’s Customer Portal. Choose the Content 

tab and select Maros/Taro library. Then search for “Tutorial” – a list of all the tutorials will be shown: 
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Figure 54: Searching at Maros/Taro library for tutorials 

Release Notes 

These Release Notes are supplied in the Help tab, as shown below. 

 

Figure 55: Release Notes at the Help Tab 

You can also find it in *.PDF form, for future reference in the installation folder. 

7 TECHNICAL HELP 

DNV GL will provide support in accordance with contractual conditions, which normally includes full 

software support, limited hardware support and optional application consultancy support. 

If you require technical support, please contact us using one of the methods below. 

7.1 Report a Problem Feature 

In order to keep improving the user experience and stability of Taro 5.3, it is really important for us to 

receive feedback in regards to any problems faced during the modelling process or even a feature 

request and change suggestion. This report can be easily sent to our Global support group by using the 

Report a Problem Feature under the Help Menu. 
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The process is simple. It consists of completing the form shown in the Figure 56 below. The Support 

Feedback application will then gather all the relevant information including operating system, software 

version and opened study files and send it to DNV GL Global Support group. 

 

When completing the form, it is also very important to provide as much information as possible to help 

us understand the problem and provide a fast and proper solution. 

You can select between three options: 

 

Figure 57: Report type 

The email report can be copied to other people by selecting the "Cc" button and entering the necessary 

email addresses. On completion of these steps press the Send button. 

Under the User Report tab enter your Name and Organization and select the Report Type you require. A 

brief description of the problem should be entered under Problem Overview, and a detailed description of 

the problem (preferably step by step) and how it can be repeated, should be provided in Detailed 

Problem Description. Any models which are currently being used will be automatically attached to the 

email. Should any other files be required, such as a Word document or Excel spreadsheet, they can be 

attached by clicking on the Add button and selecting the necessary file. The email report can be copied 

to other people by selecting the Cc button and entering the necessary email addresses. On completion of 

these steps press the Send button. 

DNV GL will then automatically receive the model(s) attached and the version number of the software 

being used. Details of the hardware specification of the machine being used, the operating system and 

the hard disk status will also be included. 

You can follow up your cases and development requests at the Customer Portal. 

Figure 56: Report a Problem 
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All you must do is log into the Customer Portal and select the Cases tab, as shown below:  

  

Figure 58: Cases at Customer Portal 

7.2 Direct email 

If you need advice on using Taro 5.3 or specific detailed technical information, you can also contact 

software.support@dnvgl.com. 

7.3 Telephone contact 

When you call please identify the application, version number and the serial number of the software 

protection key (dongle). 

In order to find the contact of your local office, please refer to the link below: 

http://www.dnvgl.com/services/software/contactus/ 

 

 

 

 

 

 

 

 

 

 

mailto:software.support@dnvgl.com
http://www.dnvgl.com/services/software/contactus/
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8 FOR SYSTEM ADMINISTRATORS: TECHNICAL NOTES 

These notes give technical details to help you improve the performance of Taro 5.3 on your system. 

They are aimed mainly at secondary support personnel (e.g. IT professionals), but may be useful for 

expert users. 

System Requirements 

Taro uses computational techniques that will depend strongly on the performance of the CPU. In general, 

the more powerful the CPU, the better the user experience. So, a twin-core CPU with a higher clock 

speed will probably outperform a quad-core CPU with a lower clock speed. Study size is another factor 

and users with large studies will benefit from as much memory as possible. 

The requirements for version 5.3 are as follows:  

Table 2: System Requirements 

 

Minimum Requirements 

(small models) 
Recommended 

Operating System: 

Windows Vista (32-bit versions) 

Windows 7 (32/64-bit versions) 

Windows 8 (32/64-bit version) 

Windows 10 (32/64-bit version) 

Windows 7 (64-bit versions) 

Computer 

Processor*: 
Intel Core or equivalent Quad Core Intel Core i5/i7 

Computer Memory: 2 GB 8 GB or more 

Clock speed (MHz) 800 MHz 3GHz or higher 

Internet Browser Supported version of Internet Explorer. 

Screen Resolution: A resolution with a minimum height of 720 pixels 

Hard disk space (MB) 650 MB (plus around 2GB of temporary disk space) 

Optional 

Requirements 

Some features depend on having Microsoft Excel installed. The product is tested 

with Office 2010 and more recent versions. 

* Note: simulation time is related to the processor speed so the faster the CPU the sooner the simulations 

run. 

  



   
 
 

 

 

 

ABOUT DNV GL 
Driven by our purpose of safeguarding life, property and the environment, DNV GL enables organizations to 

advance the safety and sustainability of their business. We provide classification and technical assurance 

along with software and independent expert advisory services to the maritime, oil and gas, and energy 

industries. We also provide certification services to customers across a wide range of industries. Operating 

in more than 100 countries, our 16,000 professionals are dedicated to helping our customers make the 

world safer, smarter and greener. 

SOFTWARE  

DNV GL is the world-leading provider of software for a safer, smarter and greener future in the energy, 

process and maritime industries. Our solutions support a variety of business critical activities including 

design and engineering, risk assessment, asset integrity and optimization, QHSE, and ship management. Our 

worldwide presence facilitates a strong customer focus and efficient sharing of industry best practice and 

standards. 


